Display issue with historical candles
Incident Report for
Hyperliquid
Resolved
This incident has been resolved.
Posted
Apr
20
,
2025
-
11:15
UTC
Investigating
There is a display issue with historical candles that is being investigated
Posted
Apr
20
,
2025
-
11:00
UTC
This incident affected: Frontend.
×
Subscribe to Incident
Subscribe to updates for
Display issue with historical candles
via . You'll receive .